PICAXE-08M RUDOLF PROJECT
1

ELECTRONIC PETS
What is a microcontroller?
A microcontroller is often described as
a 'computer-on-a-chip'. It can be used
as an ‘electronic brain’ to control a
product, toy or machine.
The microcontroller is an integrated circuit
("chip") that contains memory (to store the program), a
processor (to process and carry out the program) and input/
output pins (to connect switches, sensors and output devices like motors).
Microcontrollers are purchased 'blank' and then programmed with a specific control
program. This program is written on a computer and then 'downloaded' into the
microcontroller chip. Once programmed the microcontroller is built into a product to
make the product more intelligent and easier to use.

Example use of a microcontroller.
In most toy shops there are now lots of intelligent
'toys' available. These toys can move, make noises
and respond to being touched or being placed in a
dark place.
An example of one such toy is the 'Furby' made by
Tiger Electronics. The Furby has a microcontroller as
it's electronic 'brain' and reacts (to being touched or
being placed in the dark) by moving or making
sounds.
The Furby reacts to the outside world by sensors and
switches. It has a push switch on it's front and back,
a microswitch in it's mouth and a light sensor (LDR)
between it's eyes. There is also a microphone on it's
side so that it can detect sounds.
The Furby's movement is provided by an electric
motor. It also has a speaker to generate sounds and
an infra-red LED so that it can send signals to other
Furby's that might be nearby.
The microcontroller is the 'brain' of the creature.
Microcontrollers are powerful electronic components that have a memory and can be
programmed to switch things on and off in a special sequence. The microcontroller in
the Furby, for instance, has been programmed to switch off the motor and speaker when
the light sensor has detected it to be dark (i.e. the Furby goes to sleep).
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BLOCK DIAGRAMS

INPUT

PROCESS

OUTPUT

infra-red
receiver
light
dependent
resistor

motor
infra-red
transmitter

microcontroller

speaker
microphone
switches

The electronic system that controls the Furby toy can be drawn as a ‘block diagram’.
The light sensor, microphone and switches all provide information to the
microcontroller, and so these are known as ‘inputs’. The microcontroller then ‘decides’
how to behave and may then operate the outputs e.g. make the motor move or generate a
sound with the speaker. If another Furby is nearby they can ‘communicate’ by infra-red
signals transmitted, and received, by the microcontroller.

WHAT IS THE PICAXE SYSTEM?
The microcontrollers used in devices such as the Furby can be difficult to program, as
they generally use a complicated programming language called ‘assembler code’, which
can be quite difficult to learn.
The PICAXE system makes the microcontrollers much easier to program. The control
sequence can be drawn (and simulated) on the computer as a flowchart, or written in a
simpler programming language called BASIC. This makes it much easier to use the
microcontroller as the complicated ‘assembler code’ does not need to be learnt.
A sample BASIC program and flowchart are
shown here. In this case both programs do the
same thing - flash a light (connected to output
0) on and off every second.

start

high 0

main:
high 0
wait 1
low 0
wait 1
goto main

wait 1

low 0

wait 1
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BUILDING YOUR OWN
ELECTRONIC CYBERPET
Design Brief
Design and make an electronic ‘Rudolf the red nosed
reindeer’ Christmas decoration ‘cyberpet’. The
decoration must be programmed with it’s own
‘personality’ so that it reacts in a unique way.

Design Specification Points
1) The design will use a PICAXE-08M
microcontroller as it’s brain.
2) The design will include LED eyes and nose, a
piezo sounder to play Chrsitmas tunes and
could also optionally use a motor to generate
movement.
3) The design will be able to react to touch and
changes in light level.
4) The decoration can be designed as a flat ‘2-dimensional’ panel or as a full ‘3dimensional’ creature.

Block Diagram
The block diagram for your decoration may look like this:

INPUT

PROCESS

press switch

light
dependent
resistor

OUTPUT
LED Eyes

microcontroller

LED Nose
piezo

Designing Your Rudolf Cyberpet Decoration
Your decorationcan be any shape or size you choose, although you may also use the
standard PCB shape. You may like to design the ‘face’ of the pet using a computer
graphics program or by drawing by hand.
Things to think about:
The componets can be assembled directly on the PCB. However if you wish to make a ‘3dimensional’ project the electronic components will need to be mounted inside (or
underneath) your cyberpet decoration. The LEDs and LDR will need to poke through
holes (5mm for eyes, 10mm for nose). You should also think carefully about where the
batteries are going to be stored and where the wires are going to be connected.
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ELECTRONIC COMPONENTS
The main electrnoic components you may need for your cyberpet decoration are shown
here. The next few pages describe each of these components in more detail, and also
provide some programming ideas that may be useful when you are later programming
your rudolf cyberpet with it’s own personality:

PICAXE-08M microcontroller

light emitting diode (LED)

piezo sounder

light dependent resistor (LDR)

switch

batteries

and you will also need

picaxe download socket

resistors
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SECTION 2 - ELECTRONIC COMPONENTS
MICROCONTROLLERS
What is a microcontroller?
A microcontroller is often described as a ‘computer-on-a-chip’. It is an
integrated circuit that contains memory, processing units, and input/
output circuitry in a single unit.
Microcontrollers are purchased ‘blank’ and then programmed with a specific
control program. Once programmed the microcontroller is built into a
product to make the product more intelligent and easier to use.

Where are microcontrollers used?
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Applications that use microcontrollers include household
appliances, alarm systems, medical equipment, vehicle
subsystems, and electronic instrumentation. Some modern cars
contain over thirty microcontrollers - used in a range of
subsystems from engine management to remote locking!
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As an example, a microwave oven may use a single microcontroller to process
information from the keypad, display user information on the seven segment
display, and control the output devices (turntable motor, light, bell and magnetron).

How are microcontrollers used?
Microcontrollers are used as the ‘brain’ in electronic circuits. These electronic circuits are
often drawn visually as a ‘block diagram’. For instance a simplified block diagram for the
microwave above could be drawn like this:

INPUT

PROCESS

door
switch
keypad
switch
pushes

OUTPUT
motor

microcontroller

magnetron
light
bell

The program for the microcontroller is developed (and tested) on the computer and then
downloaded into the microcontroller. Once the program is in the microcontroller it
starts to ‘run’ and carries out the instructions.
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How are programs written?
Programs are drawn as flowcharts or typed as ‘BASIC’ listings. This is is explained in the
programming section (section 3) later in this booklet.

How is the program transferred to the microcontroller?
The PICAXE-08M microcontroller is programmed by connecting a cable from the serial
port at the back of the computer to a socket on the printed circuit board (PCB) beside
the microcontroller. This socket (which looks like a headphone socket as found on a
portable CD player) connects to two legs of the microcontroller and to 0V from the
battery. This allows the computer and the microcontroller to ‘talk’ to allow a new
program to be downloaded into the microcontroller’s memory.

Above view
of socket
x
x

x
x
x

22k
10k

7 - serial out
2 - serial in
8 - 0V

PICAXE-08

The socket and interfacing circuit is included on every PCB designed to be used with the
PICAXE-08M microcontroller. This enables the PICAXE microcontroller to be reprogrammed without removing the chip from the PCB - simply connect the cable
whenever you want to download a new program!
The circuit diagrams of PICAXE circuits often do not include the components above to
make it easier to understand the input/output connections. However the two resistors
and the socket are always built onto every PICAXE project board!

Output 0
With the PICAXE-08 system leg 7 has two functions - when a program is being run the
leg is known as output 0 and can control outputs like LEDs and motors.
When a program is being downloaded the same leg acts as the ‘serial out’ pin, ‘talking’ to
the computer. Therefore if you also have an output such as an LED connected to the leg,
you will find that the LED will flicker on and off as the program download takes place.
Note:
Most modern computers have two serial ports, normally labelled COM1 and COM2. The
Programming Editor software used to create the programs must be configured for the
correct serial port – select View>Options>Serial Port to select the correct serial port for
your machine.
If you are using a new laptop computer it may only have the newer ‘USB’ type connector.
In this case you must buy a USB to serial adapter to use the PICAXE system. These are
available from most high street computer stores or online from www.tech-supplies.co.uk
(part USB010).
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BATTERIES
What is a battery?
A battery is a self-contained source of electronic
energy. It is a portable power supply.
Batteries contain chemicals that store energy.
When connected into a circuit this chemical
energy is converted to electrical energy that can
then power the circuit.

3V

Which battery size should I use?
Batteries come in all sorts of types and sizes. Most
battery packs are made up of a number of 'cells',
and each cell provides about 1.5V. Therefore 4 cells
will generate a 6V battery and 3 cells a 4.5V battery.
As a general rule, the larger the battery the longer it
will last (as it contains more chemicals and so will
be able to convert more energy). A higher voltage
battery does not last longer than a lower voltage
battery Therefore a 6V battery pack made up of 4
AA cells will last much longer than a 9V PP3 battery, as it contains a larger total amount
of chemical energy as it is physically larger. Therefore items that require more power to
work (e.g. a CD walkman which contains a motor and laser to read the CD's) will always
use AA cells rather than PP3 batteries.
Microcontrollers generally require 3 to 6V to work, and so it is better to use a battery
pack made up of three or four AA size cells. Never use a 9V PP3 battery as the 9V supply
will damage the microcontroller.

Which battery type should I use?
Different batteries are made of different chemicals. Zinc-carbon batteries are the
cheapest, and are quite suitable for many microcontroller circuits. Alkaline batteries are
more expensive, but will last much longer when driving devices like motors that require
larger currents. Lithium batteries are much more expensive but have a long life, and so
are commonly used in computer circuits to provide a clock backup.
Rechargeable batteries can be recharged when they 'run-down'. They are generally made
up of nickel and cadmium (Ni-cad) or nickel metal hydroxide (NiMH) chemicals.
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Safety!
Never 'short circuit' any battery. Alkaline and rechargeable batteries can provide a very
large current, and can get so hot that they will actually melt the battery box if you short
circuit them! Always make sure you connect the battery around the correct way (red
positive (V+) and black negative (0V or ground)). The microcontroller chip will get hot
and be damaged if the battery is connected the wrong way around.

Using battery snaps.
Battery packs are often connected to electronic printed circuit boards by
battery snaps. Always ensure you get the red and black wires the correct
way around. It is also useful to thread the battery snap through holes on
the board before soldering it in place - this provides a much stronger
joint that is less likely to snap off.
Never accidentally connect a 9V PP3 battery to the battery snap - this will damage the
microcontroller, which only works between 3 and 6V.

Soldering to battery boxes.
Some small battery boxes require wires to be soldered to metal contacts on the battery
box. In this case you must be very careful not to overheat the metal contact. If the
contacts gets very hot they will melt the plastic and fall off. A good way of stopping this
happening is to ask a friend to hold the metal contact with a pair of small pliers. The
pliers will act as a ‘heat-sink’ and help stop the plastic melting.
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LIGHT EMITTING DIODE (LED)
What is an LED?
A Light Emitting Diode (LED) is an electronic component
that gives out light when current passes through it. An
LED is a special type of diode. A diode is a component
that only allows current to flow in one direction.
Therefore when using a diode, it must always be connected the
correct way around.
The positive (anode) leg of an LED is longer than the negative
(cathode) leg (shown by the bar on the symbol). The negative leg
also has a flat edge on the plastic casing of the LED.

What are LEDs used for?
LEDs are mainly used as indicator lights. Red and green LEDs are commonly used on
electronic appliances like televisions to show if they are switched on or in 'standby'
mode. LEDs are available in many different colours, including red, yellow, green and
blue. Special 'ultrabright' LEDs are used in safety warning devices such as the 'flashing
lights' used on bicycles. Infra-red LEDs produce infra-red light that cannot be seen by the
human eye but can be used in devices such as video remote-controls.

Using LEDs.
LEDs only require a small amount of current to work,
which makes them much more efficient than bulbs (this
means, for instance, that if powered by batteries the LEDs
will light for a much longer time than a bulb would). If
too much current is passed through an LED it will be
damaged, and so LEDs are normally used together with a
'series' resistor that protects the LED from too much
current.
The value of the resistor required depends on the battery
voltage used. For a 4.5V battery pack a 330R resistor can
be used, and for a 3V battery pack a 120R resistor is
appropriate.

pin
330R

0V

Connecting the LED to a microcontroller.
Because the LED only requires a small amount of current to operate, it can be directly
connected between the microcontroller output pin and 0V (with the series protection
resistor).
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Testing the LED connection.
After connecting the LED it can be tested by a simple program like this:
main:
high 0
wait 1
low 0
wait 1
goto main

start

high 0

wait 1

This program would switch the LED (connected to
output pin 0) on and off every second. If the LED does
not work check:
1) the LED is connected the correct way around
2) the correct resistor is used
3) the correct output pin number is being used in the
program
4) all the solder joints are good

low 0

wait 1

This program flashes the LED connected to output pin 0 on and off 15 times using a
BASIC programming technique called a for...next loop (this technique cannot be used
with flowcharts). The number of times the code has been repeated is stored in the
memory of the PICAXE chip using a ‘variable’ called b1 (the PICAXE contains 14
variables labelled b0 to b13). A variable is a ‘number storage position’ inside the
microcontroller than the microcontroller can use to store numbers as the program is
carried out.
main: for b1 = 1 to 15
high 0
pause 500
low 0
pause 500
next b1
end

‘
‘
‘
‘
‘
‘

start a for...next loop
switch pin 0 high
wait for 0.5 second
switch pin 0 low
wait for 0.5 second
end of for...next loop

‘ end program
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BUZZERS AND PIEZO-TRANSDUCERS
What is a piezo transducer?
A piezo transducer is a low-cost 'mini-speaker' that can used to
make sounds and play tunes. The sound that the piezo makes
can be changed by altering the electronic signals provided by the
microcontroller.

Where are piezos used for?
Piezos are used in many different consumer goods to provide 'feedback' to the user. A
good example is a vending machine which will 'beep' whenever a keypad switch is
pressed to select a drink or snack. The 'beep' provides the user with feedback to tell them
their switch push has been successful. Uncased piezos are also often used in musical
birthday cards to play a tune when the card is opened.

What is the difference between a piezo and a buzzer?
A buzzer contains a small electronic circuit that generates the electronic signal needed to
make a noise. Therefore when a buzzer is connected to a battery it will
always make the same sound. A piezo does not contain this circuit, and so
therefore needs an external signal. This signal can be supplied by the
output pin of a microcontroller. A piezo also requires less current to
operate and so will last longer in battery powered circuits.

Using piezos.
A piezo is very simple to connect. Simply
connect the red wire to the microcontroller
output pin and the black wire to 0V
(ground).
Note that the cheapest piezos do not have a
plastic casing to them. In this case it is
necessary to mount the piezo on a piece of
board (with a sticky pad) to create a noise
that can be heard. The board acts as a
'sound-box' to amplify the sound made by
the piezo. Make sure the sticky pad is stuck
on the correct side of the piezo (the brass side
without the wires!).

pin

pin
+

40R
0V

0V

Making More Noise.
Some times you might want to make a louder noise. In this case it is
possible to use a speaker instead of the piezo. When using a speaker
it is also necessary to use a capacitor (e.g. 10uF electrolytic capacitor)
to prevent damage to the microcontroller.
Remember that, like the piezo, a speaker only works correctly when
mounted in a 'sound-box'.
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Testing the piezo connection.
After connecting the piezo it can be tested by a simple program like this:
main:
play 3,3
pause 1000
goto main
This program would make the piezo (connected to output pin 2) play the ‘rudolf the red
nosed reindeer’ tune. The LEDs on the nose and eyes will also flash whilst the tune is
played. If the piezo does not work check:
1) the piezo is correctly mounted
2) all the solder joints are good

Choosing a tune
The PICAXE-08M has 4 tunes pre-programmed. These tunes are as follows:
play 3,0
‘ Happy Birthday
play 3,1
‘ Jingle Bells
play 3,2
‘ Silent night
play 3,3
‘ Rudolf the Red Nosed Reindeer
However it is also possible to import your own mobile phone ring tone (RTTTL format
for Nokia phones). This tune can then be played on the PICAXE-08M with the ‘tune’
command. Therefore if you download a Christmas Carol or tune in ring tone format
from the internet, you can play this on your Rudolf cyberpet. There are many free
Christmas tunes to download on the software page at www.picaxe.co.uk

PICAXE-08M Tune Wizard
The Tune Wizard allows musical tunes to
be created for the PICAXE-08M. Tunes can
be entered manually using the drop-down
boxes if desired, but most users will prefer
to automatically import a mobile phone
monophonic ringtone. These ringtones
are widely available on the internet in
RTTTL format (used on most Nokia
phones). Note the PICAXE can only play
one note at a time (monophonic), and so
cannot use multiple note (polyphonic)
ringtones.
There are approximately 1000 tunes for free download on the software page of the
www.picaxe.co.uk website. Some other possible sources for free ringtones are:
http://www.ringtonerfest.com/
http://www.free-ringtones.eu.com/
http://www.tones4free.com/
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To start the Tune Wizard click the PICAXE>Wizard>Tune Wizard menu.
The easiest way to import a ringtone from the internet is to find the tune on a web page.
Highlight the RTTTL version of the ringtone in the web browser and then click
Edit>Copy. Move back to the Tune Wizard and then click Edit>Paste Ringtone.
To import a ringtone from a saved BASIC (.bas) text file, click File>Import Ringtone.
Once the tune has been generated, select whether you want outputs 0 and 4 to flash as
the tune plays (from the options within the ‘Outputs’ section).
The tune can then be tested on the computer by clicking the ‘Play’ menu (if your
computer is fitted with soundcard and speakers). The tune played will give a rough idea
of how the tune will sound on the PICAXE, but will differ slightly due to the different
ways that the computer and PICAXE generate and playback sounds. On older computers
the tune generation may take a couple of seconds as generating the tune is very memory
intensive.
Once your tune is complete click the ’Copy’ button to copy the tune command to the
Windows clipboard. The tune can then be pasted into your main program.
Tune Wizard menu items:
File

Edit

Play
Help

New
Open
Save As
Import Ringtone
Export Ringtone
Export Wave
Close
Insert Line
Delete Line
Copy BASIC
Copy Ringtone
Paste BASIC
Paste Ringtone
Help

Start a new tune
Open a previously saved tune
Save the current tune
Open a ringtone from a text file
Save tune as a ringtone text file
Save tune as a Windows .wav sound file
Close the Wizard
Insert a line in the tune
Delete the current line
Copy the tune command to Windows clipboard
Copy tune as a ringtone to Windows clipboard
Paste tune command into Wizard
Paste ringtone into Wizard
Play the current tune on the computer’s speaker
Start the help file.

Ring Tone Tips & Tricks:
1. After generating the tune, try adjusting the tempo by increasing or decreasing the
speed value by 1 and listening to which ‘speed’ sounds best.
2. If your ringtone does not import, make sure the song title at the start of the line is
less than 50 characters long and that all the text is saved on a single line.
3. Ringtones that contain the instruction ‘d=16’ after the description, or that contain
many notes starting with 16 or 32 (the odd one or two doesn’t matter) will not play
correctly at normal speed on the PICAXE. However they may sound better if you
double the PICAXE processor speed by using a ‘setfreq m8’ command before the
tune command.
4. The PICAXE import filters ‘round-down’ dotted notes (notes ending with ‘.’). You
may wish to change these notes into longer notes after importing.
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DIGITAL SENSORS (SWITCHES)

What are switches?
A digital sensor is a simple ‘switch’ type sensor that can only be ‘on’ or ‘off’. If a graph is
drawn of the on-off signals as the switch is pushed it will look like this:

Voltage

5V

0V

Time

Switches are electronic components that detect movement. There are a large number of
different types of switches e.g:
push switches that detect a momentary 'push'
micro-switches with long levers that detect small movements
tilt-switches that detect jolting
reed-switches that detect a magnet being moved

What are switches used for?
Push switches are commonly used on device like keypads. Micro-switches are used in
burglar alarms to detect if the cover is removed from the alarm box. Reed switches are
used to detect doors and windows being opened and tilt switches are often used to detect
movement in devices such as toys, hair-dryers and tool-box alarms.

Switch Symbols.
The symbols for a slide switch
and a push switch are shown here.
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Using switches
A switch is used with a resistor as shown in the diagram. The
value of the resistor is not that important, but a 10k resistor
is often used. When the switch is 'open' the 10k resistor
connects the microcontroller input pin up to V+, which
gives a logic level 1 (4.5V) signal to the microcontroller
input pin.

V+
10k
Pin3

When the switch is activated, the input pin is connected to
the negative (ground) supply (0V). This provides a logic
level 0 (0V) signal to the microcontroller.

0V

This layout is a little confusing, as it means that when the switch is pushed down, the
logic level is ‘0’. When the switch is not pushed the logic level is ‘1’. This is known as an
‘active-low’ switch. In this project this is necessary for compatability with the optional
infra-red upgrade kit.

Testing the switch
After connecting the switch it can be tested by a simple program like this. This program
will switch an output on and off according to if the switch is pushed or not.
main:
if input3 = 0 then flash
goto main
flash:
high 0
wait 2
low 0
goto main

‘ make a label called ‘main’
‘ jump if the switch is pressed
‘ else loop back around
‘
‘
‘
‘
‘

make a label called ‘flash’
switch output 0 on
wait 2 seconds
switch output 0 off
jump back to start

In this program the first three lines make up a
continuous loop. If the input is off the program
just loops around time and time again.
If the switch is then pushed the program jumps to
the label called ‘flash’. The program then flashes
output 0 on for two seconds before returning to
the main loop.

start

pin3=1

Y

N

Note carefully the spelling in the if…then line –
input3 is all one word (without a space). You can
use the word pin3 or input3 to mean the same
thing. Note also that only the label is placed after
the command then – no other words apart from a
label are allowed at this point.

high 0

wait 2

low 0
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LIGHT DEPENDENT RESISTOR (LDR)
What is an LDR?
A Light Dependent Resistor (LDR) is special type of resistor that reacts to changes in light
level. The resistance of the LDR changes as different amounts of light fall on the top
'window' of the device. This allows electronic circuits to measure changes in light level.

R(W)

LDR

Light intensity
(Lux)
dark

light

What are LDRs used for?
LDRs are used in automatic street lamps to switch them on at night and off during the
day. They are also used within many alarm and toys to measure light levels.
The LDR is a type of analogue sensor. An analogue sensor measures a continuous signal
such as light, temperature or position (rather than a digital on-off signal like a switch).
The analogue sensor provides a varying voltage signal. This voltage signal can be
represented by a number in the range 0 and 255 (e.g. very dark = 0, bright light = 255).

light

Voltage

5V

dark

0V

Time
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Using LDRs.
A LDR can be used in two ways. The simplest way to use an LDR is
as a simple on-off ("digital") switch - when the light level is above
a certain value (called the 'threshold value') the LDR will provide
an on signal, when the light level is below a certain value the LDR
will provide an off signal.
In this case the LDR is used in a potential divider with a standard
resistor. The value of the standard resistor sets the 'threshold value'.
For miniature LDRs a suitable value may be 1k or 10k, for larger
ORP12 type LDRs 10k is more appropriate. If desired the fixed
resistor can be replaced by a variable resistor so that the threshold
value can be 'tuned' to different light values.

10k

A more versatile way of using the LDR is to measure a number of different light values, so
that decisions can be made at varying light levels rather than just one fixed threshold
value. A varying value is known as an 'analogue' value, rather than a digital 'on-off' value.
To measure analogue values the microcontroller must contain an 'analogue to digital
converter (ADC)' and the programming software must support use of this ADC. Most
microcontrollers only contain ADC on certain input pins, and so the input pin
connection must be carefully selected. With the 8 pin microcontroller only pin1 can be
used.
The electronic circuit for using the ADC is a potential divider identical to the circuit
above. The analogue 'measurement' is carried out within the microcontroller itself.

Calibrating the LDR (used as analogue input)
When using analogue sensors it is often necessary to calculate the ‘threshold’
value necessary for the program (ie the values 50 and 100 in the analogue
program overleaf). The debug command provides an easy way to see the ‘realtime’ value of a sensor, so that the threshold value can be calculated
by experimentation.
main:
readadc 1,b1
debug b0
pause 500
goto main

‘
‘
‘
‘
‘

make a label called main
read channel 1 into variable
transmit value to computer
short delay
jump back to the start

After this program is run a ‘debug’ window showing the value of variable b0
will appear on the computer screen. As the Light falling on the LDR sensor is
altered, the variable value will show the current sensor reading.
The debug window opens automatically after a download, but can also be opened
manually at any time via the PICAXE>Debug menu.
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Testing the LDR (digital)
After connecting the LDR it can be tested as a
digital switch by a simple program like this:

start

main:
pin1=1

if input1 is on then dohigh
low 0
goto main

Y

N
low 0

dohigh:
high 0
goto main

high 0

This program will switch output 0 on and off according to the light level.

Testing the LDR (analogue)
After connecting the LDR it can be tested as
an analogue sensor by a program like this:

start

main:
readadc 1,b1
if b1 > 100 then do4
if b1 > 50 then do0
low 0
low 4
goto main

readadc 1,b1

b1> 100

N
b1> 50

do4:
high 4
low 0
goto main

Y

Y

N
low 0

high 0

high 4

low 4

low 4

low 0

do0:
high 0
low 4
goto main

The ‘readadc’ command is used to read the analogue value (a number between 0 and
255) into variable b1. Once the number is in variable b1 it can be tested to see if it is
greater than 100 or greater than 50. If it is greater than 100 output 4 is switched on, if it is
between 50 and 100 output 0 is switched on, and if it is less than 50 both outputs are
switched off.
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SECTION 3
PROGRAMMING - DRAWING FLOWCHARTS
Flowcharts are a useful tool that allow programs to be drawn graphically to make them
easier to understand. The Programming Editor software includes a flowchart editor that
allows flowcharts to be drawn on screen. These flowcharts can then be converted to
BASIC listings for download into the PICAXE. The flowcharts can also be printed or
exported as graphics files for inclusion within project portfolios.
Detailed instructions for drawing/downloading a flowchart:
1.
2.
3.
4.
5.
6.
7.
8.

9.

Connect the PICAXE cable to the computer serial port. Note which port it is
connected to (normally labelled COM1 or COM2).
Start the Programming Editor software.
Select View>Options to select the Options screen (this may automatically appear).
Click on the ‘Mode’ tab and select PICAXE-08
Click on the ‘Serial Port’ tab and select the serial port that the PICAXE cable is
connected to. Click ‘OK’
Start a new flowchart by clicking the File>New Flowchart menu.
Draw the flowchart by dragging the correct symbols onto the screen, and then using
the mouse to draw arrows between the symbols.
Once the flowchart is complete it can be converted into a BASIC program by
selecting Flowchart>Convert Flowchart to BASIC. The BASIC program can then be
downloaded into the PICAXE by clicking the PICAXE>Run menu.
To print or save the flowchart, use the File menu options. To export the flowchart as
a graphic file, use the File>Export menu. To publish the image in a Word document
select file type EMF. To publish the flowchart on an internet web page use the GIF
file type.
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Flowchart Screen
The Flowchart Editor allows flowcharts to be drawn and simulated on-screen. The
flowchart can then be automatically converted into a BASIC program for downloading
into the microcontroller.
Select Zoom Zoom In/Out Pan Line Out If Delay Sub Other

edit bar

Flowchart Screen
Select Tool
Use this to select and move shapes. When a single shape is selected it’s BASIC code can
be edited in the edit bar at the bottom of the window.
Zoom
Use to zoom in to an area of the graph. Right click to zoom out.
Zoom In/Out
To zoom in click and move the mouse up. To zoom out click and move the mouse down.
Pan
Use this tool to move around the flowchart.
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Line Tool
Use this tool to draw lines between shapes. Corners can be added by clicking once. When
the line is near to a shape it will ‘snap’ to the connection point.
Label Tool
Use this tool to add descriptive labels or titles to the flowchart.
Out / If / Delay / Sub / Other
Click on these buttons to move to the command sub-menu to select commands.

Drawing Flowcharts
To draw a flowchart click on one of the command menu buttons (out / if / delay / sub /
other) on the toolbar to move to the appropriate command sub-menu. Select the
appropriate command and then click on the screen where the shape is required. Do not
try to locate the shape precisely at first – just drop it in the general area and then use the
select tool to move the shape to the correct position.
Once the shape is in position click on it so that it is highlighted. The BASIC code for the
shape will then appear in the edit bar at the bottom of the screen. Edit the code as
required.
For further information about each command see the ‘BASIC Commands’ help file.

Joining Shapes
Shapes are joined by moving them close together until they ‘snap’ together. Alternately
lines can be drawn between the shapes using the ‘line tool’ from the main toolbar. Note
that it is only possible to join the bottom (side) of shapes to the top of other shapes
(you cannot connect lines to lines). Only one line is allowed out of the bottom of each
shape.
To enable neat diagrams, corners to the lines can be added by clicking with the mouse.
When a line moves close to a connection point it will snap into position and then a click
will finish the line.
Lines cannot be moved. If you try to move a line it will be deleted and a new line must
be created.
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On Screen Simulation

To simulate the flowchart, click ‘Simulate’ from the Flowchart menu. The program will
then start to run on-screen.
As the program runs each cell is highlighted red as it is carried out. The ‘Inputs/Outputs’
and ‘Variables’ windows also appear when a simulation is being carried out. To adjust
the input values click the on-screen switch (shown beneath the output LED) or slide the
analogue input slider.
The time delay between shapes can be adjusted via the Flowchart options
(View>Options>Flowchart menu).
Note that certain commands have no on-screen simulation equivalent feature. In this
case the command is simply ignored as the flowchart runs.
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Downloading Flowcharts
Flowcharts are not directly downloaded to the microcontroller. First the flowchart is
converted into a BASIC program, which is then downloaded.
To convert a program select ‘Convert’ from the Flowchart menu. The BASIC program for
downloading will then be created.
Shapes that are not connected to the ‘start’ or ‘sub’ shapes in the flowchart are ignored
when the conversion takes place. The conversion will stop if an unconnected shape is
found. Therefore always use a ‘stop’ shape or line to complete the flowchart before
simulation or conversion.
Note that it is possible to quickly convert and then download a flowchart by pressing the
shortcut key <F5> twice.

Using Symbols
Inputs, Outputs and Variables can all be renamed using the ‘Symbol Table’ from the
Flowchart menu. When a symbol is renamed the new name appears in the drop-down
menus on the edit bar. Note that you should not use commands (e.g. switch or sound) as
a symbol as this will generate errors in your converted BASIC program.

Saving and Printing Flowcharts
Flowcharts can be saved, printed and exported as graphic files (for adding to word
processor documents) via the File menu. Flowcharts can also be copied to the Windows
clipboard (for pasting into other applications) via the Edit menu.
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SECTION 4
PROGRAMMING - BASIC
Programming in BASIC is more powerful than using flowcharts. This is because BASIC
contains more commands, eg. for...next loops, which cannot be used with the graphical
flowchart methods. However you have to be more accurate in your ‘typing’ as no spelling
mistakes are allowed!
The following program is a sample BASIC program which switches output 0 on and off
every second. When you download the program an LED connected to output 0 would
flash on and off every second..
main:
high 0
pause 1000
low 0
wait 1
goto main
This program uses the high and low commands to control output pin 0, and uses the
pause and wait commands to make a delay. Wait uses whole second units, whilst pause
uses 1 millisecond (ms) units (1000 ms = 1 second). Therefore in this program both the
delays are the same, just written in different ways.
The last goto main command makes the program ‘jump’ back to the label main: at the
start of the program. This means the program loops forever. Note that the first time the
label is used it must be followed by the colon (:) symbol. This tells the computer the
word is a new label.
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Detailed instructions:
1.
1.
2.
3.
4.
5.

Connect the PICAXE cable to the computer serial port. Note which port it is
connected to (normally labelled COM1 or COM2).
Start the Programming Editor software.
Select View>Options to select the Options screen (this may automatically appear).
Click on the ‘Mode’ tab and select PICAXE-08
Click on the ‘Serial Port’ tab and select the serial port that the PICAXE cable is
connected to. Click ‘OK’
Type in the following program:
main:
high 0
pause 1000
low 0
wait 1
goto main
(NB note the colon (:) directly after the label ‘main’ and the spaces between the
commands and numbers)

6.
7.

Make sure the PICAXE circuit is connected to the serial cable, and that the batteries
are connected.
Select PICAXE>Run. A download bar should appear as the program downloads.
When the download is complete the program should start running automatically –
the LED on output 0 should flash on and off every second.
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Programming Editor Software Reminders:
Toolbar short-cuts:

To download/run a BASIC program:
1. Check the download cable is connected to the PICAXE and the computer’s serial
port
2. Check that the battery is connected to the PICAXE
3. Make sure the Programming Editor software is in the correct mode (look for
‘PICAXE-08’ in the statusbar at the bottom left of the screen).
4. Click PICAXE>Run (or the toolbar icon) (or press the shortcut key F5)
To save a program/flowchart:
1. Click File - Save As... (or the toolbar icon)
2. Type in a filename
3. Click <OK>
To open a saved program/flowchart:
1. Click File - Open... (or the toolbar icon)
2. Select the file type (BASIC or flowchart)
3. Select a filename from the list by clicking on it
4. Click <OK>
To start a new BASIC program:
1. Click File - New
To start a new flowchart:
1. Click File - New Flowchart (or the toolbar icon)
To on-screen simulate a flowchart:
1. Click Flowchart - Simulate... (or the toolbar icon)
2. Click on the flowchart to stop the simulation
To convert a flowchart to BASIC:
1. Click Flowchart - Convert to BASIC... (or press the shortcut key F5)
To print a program/flowchart:
1. Click File - Print... (or the toolbar icon)
2. If you want each program line printed in A BASIC program to have a number, make
sure the ‘Print Line Numbers’ box is checked
3. Click <OK>
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SECTION 5 - THE RUDOLF ‘CYBERPET’ PCB
The Rudolf project uses a PICAXE-08M microcontroller with two LEDs as the pets ‘eyes’,
a large LED as the nose and a piezo sounder as a ‘voice’ for the decoration.
The project also uses a switch so that the cyberpetcan respond to ‘touch’, and a Light
Dependent Resistor (LDR) so that the pet can tell whether it is light or dark.

INPUT

PROCESS

OUTPUT

press switch

LED Eyes

light
dependent
resistor

microcontroller

LED Nose
piezo

The electronic block diagram is shown below.
output - pin0 and pin4 are connected to the LEDs
output - pin2 is connected to the piezo sounder
input - pin1 is connected to the LDR
input - pin3 is connected to the push switch
Remember not to confuse the chip ‘leg’ number with the input/output pin number!

Circuit Diagram
The circuit diagram for the Rudolf cyberpet decoration project is shown below:

4.5V

330

4k7

Rudolf the Red Nosed Reindeer Circuit

330 x 3

LDR

4

10k

in3

6

PICAXE 08M

1
in1

out4

3
7

out0

5

22k

Serial
Link

piezo
10k

+ 4u7

eyes

out2

8
IR

nose

sin

2

0V
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BUILDING THE RUDOLF PCB
What you will need:
R1 and R2
R3
R4-8
R9
LED1 and 2
LED3
PZ
LDR
SW1
IC1
IC1
SOCKET
BT1
BT1
PCB

10k resistor
(brown black orange gold)
22k resistor
(red red orange gold)
330R resistor
(orange orange brown gold)
4k7 resistor
(yellow violet red gold)
5mm green LED
10mm red LED
piezo sounder
miniature light dependent resistor
miniature 6mm switch
8 pin IC socket
PICAXE-08M microcontroller
PICAXE download 3.5mm socket
battery clip
4.5V (3xAA) battery box
printed circuit board

The components C1 and IR are part of the optional
infra-red upgrade kit and are not needed unless this
upgrade is used.

Resistor colour codes

Tools:
soldering iron and solder
side cutters

Black

0

0

Black x1

Silver ±10%

Brown

1

1

Brown x10

Gold ±5%

Red

2

2

Red x100

Orange

3

3

Orange x1000

Yellow

4

4

Yellow x10,000

Green

5

5

Green x100,000

Blue

6

6

Blue x1,000,000

Violet

7

7

Example shown:

Grey

8

8

blue, grey, brown, gold

White

9

9

= 680R ±5%
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Soldering the PCB.
The printed circuit board (PCB) is specially manufactured with a ‘solder resist’ layer to
make it simpler to solder. This is the green ‘lacquer’ layer that covers the tracks so that the
solder does not stick to these tracks. However for successful assembly the PCB must be
carefully assembled and soldered.
When soldering always make sure the solder iron tip is hot and clean. To test if it is hot
enough try to melt a piece of solder on the tip. The solder should melt almost instantly.
Then clean off the melted solder by wiping the tip on a damp sponge.
Remember that solder will only ‘stick’ to hot surfaces. Therefore never melt the solder on
the soldering iron tip and then try to ‘drop’ it onto the joint – this won’t work as the
joint will be cold and so the solder won’t stick.
To successfully solder you must hold the soldering iron in one hand and the solder in the
other. Therefore make sure the board is held on the table so it won’t move (e.g. use a
bulldog clip or get someone else to hold it for you).
Steps to soldering:
1) Clean the soldering iron tip on the damp sponge
2) Press the soldering iron tip against the pad on the PCB AND the leg of the
component. Count to 3 to give the joint time to warm up.
3) Keep the soldering iron in position and touch the solder against the joint. Allow
enough solder to melt to cover the joint.
4) Take the solder away first, then the soldering iron
5) Allow the solder to cool for about 5 seconds before trying to move the board.
After each joint is made make sure it does not accidentally ‘bridge’ across to other joints.
However be aware that some solder joints (e.g. on the two sides of the PICAXE download
socket) have two wires very close together that are already connected by a track (line) on
the PCB. In this case it does not matter if the solder joins together.

Tips!

Supported by:

1) Always start with the smallest components like the resistors. Then move onto larger
components like the IC socket and then finish with the tall components like
capacitors and transistors. Do not try to put all the components in position at once,
only do two or three at a time.
2) Always make sure that the components lie flat on the board before they are soldered.
When using components with long legs like resistors and LEDs, bend the legs so that
the component is held firmly in position before soldering.
3) Make sure the PICAXE stereo download socket ‘snaps’ into position flat on the board
before it is soldered.
4) Make sure that the components that only work one way around (LEDs, diodes,
transistors and capacitors) are correctly aligned before soldering (see the marks on
the PCB).
5) Piezo sounder wires are very thin. Make sure you do not overheat them or they may
melt.
6) Always thread the battery snap wires down and up through the two thread holes
before soldering. This helps make a much stronger joint which is less likely to snap
off.
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Soldering the PCB
1) Very carefully remove the optional
‘infra-red upgrade’ PCB from between
the two ‘antlers’. Smooth down any
rough spots on the edge of the PCB.
2) Place the 4k7(yellow violet red gold
gold) and two 10k (brown black
orange gold) resistors in position.
Bend the legs to hold the resistors in
position and then solder.
3) Place the 22k (red red orange gold)
and four 330 (orange orange brown
gold) resistors in position. Bend the
legs to hold the resistors in position
and then solder.
4) Push the PICAXE stereo download
socket onto the PCB and make sure it
clicks into position (so that it lies flat
on the board). Solder the five metal
square contacts (the five round plastic
support post holes do not have to be
soldered). Do not worry if the solder
joins on the two metal contacts either
side of the socket, as they are
supposed to be joined anyway.
5) Push the IC socket into position. Make sure the notch at one end points up towards
the socket. Fold the legs over to hold the socket in position and then solder.
6) Solder the LDR and three LEDs into position. Make sure the flat on one side of the
LED aligns with the flat marked on the PCB (long leg of LED is positive +).
7) Solder the switch in position (note that it only fits one way around).
8) Thread the battery clip up through the large hole by the letters ‘4.5V’. Then solder
the black wire in the hole marked BLK and the red wire in the hole marked RED.
9) If using a ‘plastic cased’ piezo sounder solder it in place on the left antler. If using a
economy flat ‘brass’ piezo, use 1/2 a sticky pad to stick the piezo sounder (brass
side) to the top of the PCB. Thread the wires down through the hole on the right of
the antler and back up through the hole marked on the left. Solder the red wire into
the bottom hole (nearest the printed circle) and the black wire into the top hole.
10) Carefully check the board to make sure there are no missed joints or accidental
solder bridges.
11) Insert the microcontroller into the socket, ensuring pin1 faces the stereo socket.
12) Note the PICAXE-08M chip will require programming before the project will
function. See the full rudolf datasheet for program examples.
The full 40 page rudolf datasheet (AXE107.pdf) can be downloaded from the datasheets
section of www.picaxe.co.uk
or from within the Help>PICAXE08 menu of the Programming Editor software.
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Testing your circuit.
Step 1 – Check the solder joints.
Check that all the joints are connected to both the pad and the wire, and that the wire is
held firmly so that it does not ‘wobble’ when pulled. Also check that the solder does not
accidentally bridge between two pads. This is most likely to happen on the LEDs, the
LDR and on the piezo. On the stereo socket the two square pads close together on each
side can be joined as they are already joined by a track on the board. However they must
not be joined to the central round hole.

Step 2 - Check the components.
1) Check that the black battery clip wire is in the hole marked ‘BLK’ and the red battery
clip wire is in the hole marked ‘RED’
2) Check that the PICAXE-08M chip is in the socket correctly, with the dent (showing
pin1) closest to the stereo socket.
3) Check that the flat edge of the LED is connected to the correct hole on the PCB.
4) Make sure the brass side of the piezo is stuck down with a sticky pad.
5) Check that the socket is correctly soldered, including the middle square pad which is
often forgotten by mistake.

Step 3 - Connect the battery.
Check the 3 AA batteries are in the battery box correctly. Connect the battery box to the
battery snap and put your finger on the PICAXE chip. If it starts to get hot remove the
battery box immediately as there is a problem – most likely that the chip or the battery
snap wires are around the wrong way.
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Step 4 – Download a program to test ‘nose’ LED.
Connect the cable to the back of the computer and to the PICAXE socket on
the PCB. Make sure the cable is pushed fully into the socket
start
on the PCB.
Make sure the software is in the PICAXE-08M mode and the
correct serial port is selected (see section 4 of this booklet for
more information).

high 0

wait 1

Type in and download the following program:
program like this:

low 0

main:
wait 1

high 0
wait 1
low 0
wait 1
goto main

The nose LED should flicker as the program downloads. After the download is complete
the LED should flash on and off every second. If the LED does not flash check that it is
around the correct way and that the 330R resistors are in the correct positions on the
PCB.
If the program does not download check that the 22k, 10k, socket and IC socket are all
soldered correctly. Use a multimeter to make sure you are getting 4.5V across the top legs
(1 and 8) of the microcontroller. Check that the cable is pushed firmly into the socket
and that the correct serial port is selected within the software.

Step 5 – Test the eye LEDs
Repeat the program in step 4, but use high 4 and low 4 instead of high 0 and low 0. This
will test the two eye LEDs.

Step 6 – Test the piezo
Type in and download the following program:
main:
play 3,3
pause 1000
goto main
The piezo should play the ‘rudolf’ tune. If it does not make sure the wires are correctly
soldered, that it is stuck on the brass side with a sticky pad (it will not work if ‘hanging
loose’). Note that louder tune will be heard with the better quality plastic cased piezo.
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Step 7 – Test the switch
Type in and download the following program.
main:
if input3 = 0 then flash
goto main
flash:
high 0
wait 2
low 0
goto main

‘ make a label called ‘main’
‘ jump if the switch is pushed
‘ else loop back around
‘
‘
‘
‘
‘

make a label called ‘flash’
switch output 0 on
wait 2 seconds
switch output 0 off
jump back to start

start

pin3=1
N

Y
high 0

wait 2

low 0

The LED on output 0 should light whenever the switch is pushed. If it does not check
that the switch and 10k resistors are correctly soldered.
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Step 8 – Test the LDR
Type in and download the following
program.

readadc 1,b1

main:
readadc 1,b1
if b1 > 100 then do4
if b1 > 50 then do0
low 0
low 4
goto main
do4:
high 4
low 0
goto main

b1> 100

Y

N
b1> 50

Y

N
low 0

high 0

high 4

low 4

low 4

low 0

do0:
high 0
low 4
goto main
NOTE You may need to change the threshold values if it is dark in the room. e.g. try 60
and 30 instead of 100 and 50
The LEDs should light in different patterns as you raise and lower your hand over the
LDR (so that different amounts of light fall on the LDR). If they do not check that the
LDR and 10k resistor are correctly soldered.
If all these tests pass, you can be congratulated as you have correctly built and
assembled your Rudolf Cyberpet Decoration! It is now time to develop and test your
own program to give it a personality!
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SECTION 6 - PROGRAM IDEAS.
Now that you have assembled and tested your Rudolf cyberpet, it is time to give it a
‘personality’ by developing your own program. This program can make the pet react in
different ways to the light and push switch sensors.

Included on the next pages are two example programs. These are designed to give you a
starting point for your program. You may choose to modify them or to start a completely
new program if you prefer.

Be creative!
Your Rudolf cyberpet is your creation so give it an exciting
personality! Remember you can download any RTTTL mobile phone
ring tone by use of the PICAXE-08M Tune Wizard.

Program 1 Explanation
This program has a main loop which scans the switch. When the switch is pushed one of
four tunes will play. The tune selected depends on the light level falling on the LDR when
the switch is pushed.

Program 2 Explanation
This program is more advanced, and demonstrates how to use the interrupt to stop a
tune part way through playing. When the LDR is covered the rudolf tune starts playing. If
the switch is pressed whilst the tune is playing the tune will stop.

Supported by:

revolution

Revolution Education Ltd. Email: info@rev-ed.co.uk Web: www.rev-ed.co.uk
© copyright 2004 - AXE107 Rudolf Student Project Notes Version 1.1

35

PICAXE-08M RUDOLF PROJECT
36

Program 1
' ***** main loop *****
' wait until switch pushed
main:
if pin3 = 0 then playit
goto main
' ***** play tune *****
'wait until switch is released
playit:
pause 10
if pin3 = 0 then playit
readadc 1,b1
'debug b1
' play tune
if b1
if b1
if b1

Note this must be
typed as one long
line in the software

' read light level
' optional display on screen for testing

depending on light level
> 200 then play_xmas
> 150 then play_rudolf
> 80 then play_silent

play_jingle:
play 1,3
goto main

' internal tune Jingle Bells

play_silent:
play 2,3
goto main

' internal tune Silent Night

play_rudolf:
play 3,3
goto main

' internal tune Rudolf The Red Nosed Reindeer

play_xmas:

' external ringtone tune (from Tune Wizard)

' We wish you a Merry Xmas
tune 3, 4, ($22,$27,$67,$69,$67,$66,$24,$24,$24,$29,$69,$6B,$69,$67,
$26,$22,$22,$2B,$6B,$40,$6B,$69,$27,$24,$22,$24,$29,$26,$E7,$22,$27,
$67,$69,$67,$66,$24,$24,$24,$29,$69,$6B,$69,$67,$26,$22,$22,$2B,$6B,
$40,$6B,$69,$27,$24,$22,$24,$29,$26,$A7,$22,$27,$27,$27,$E6,$26,$27,
$26,$24,$E2,$29,$2B,$69,$69,$67,$67,$02,$22,$22,$24,$29,$26,$E7)
goto main
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Program 2
' ***** main loop *****
' wait until light level low
main:
readadc 1,b1
' read light level
'debug b1
' optional display on screen for testing
if b1 < 100 then playit
goto main
' ***** play tune *****
playit:
'enable interrupt on switch push
setint %00000000, %00001000
' play tune
play 3,3
setint 0, 0
goto main

' play rudolf
' ok so interrupt off

; ***** interrupt - stop tune if switch pushed *****
interrupt:
pause 10
if pin3 = 0 then interrupt
return
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APPENDIX A - INFRA-RED UPGRADE (AXE108K)

The Rudolf project PCB is supplied with a small optional ‘infra-red’ upgrade PCB. When
populated with components, this infra-red PCB can be used to remotely control the
Rudolf Cyberpet decoration. The components required are supplied in kit AXE-108K.
Note the small push switch on the main Rudolf PCB shares the same input pin (input3)
as the infra-red sensor and so should not be used within the main program after
connecting the sensor. It is not necessary to remove the switch from the PCB.
Components for main Rudolf PCB
IR
LED020 infra-red receiver
C!
4u7 capacitor
Components for infra-red PCB
R1-3
10k resistor
(brown black orange gold)
R4
330R resistor
(orange orange brown gold)
R-IR
330R resistor
(orange orange brown gold)
LED
5mm yellow LED
IR
5mm infra-red LED (may be clear or black in colour)
SW1-3
miniature 6mm switch
IC1
8 pin IC socket
IC1
PICAXE-08M microcontroller
BT1
battery clip
BT1
4.5V (3xAA) battery box
PCB
printed circuit board (NB: supplied with main Rudolf Kit)

Main ‘Rudolf PCB’ modification

Supported by:

1) Place the IR receiver in position IR. Fold the legs by 90 degrees so the receiver is lying
flat on the PCB with the curved side up and facing out. Solder in position.
2) Place the 4u7 capacitor in position C1, ensuring the positive (+) leg is in the top
hole. Solder in position.
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Infra-red Upgrade PCB
1) Place the infra-red resistor (R-IR) (330 orange orange brown gold) and 330 (orange
orange brown gold) resistors in position. Bend the legs to hold the resistors in
position and then solder.
2) Place the three 10k (brown black orange gold) resistors in position. Bend the legs to
hold the resistors in position and then solder.
3) Use an off-cut resistor leg to make a wire link in the position LK. This link lies under
the 8 pin socket so ensure that the link is lying flat on the PCB before soldering in
position.
4) Push the IC socket into position. Make sure the notch at one end points up towards
the LEDs. Fold the legs over to hold the socket in position and then solder.
5) Solder the yellow LED into position LED. Make sure the flat on one side of the LED
aligns with the flat marked on the PCB.
6) Using a pair of pliers, put a 90 degree bend in the infra-red-LED legs so that it points
out from the PCB (see photo on previous page). Solder the infra-red LED into
position IR. Make sure the flat on one side of the LED aligns with the flat marked on
the PCB.
7) Solder the three switches in position (note that they only fit one way around).
8) Thread the battery clip up through the large hole by the bottom switch. Then solder
the black wire in the hole marked BLK and the red wire in the hole marked RED.
9) Carefully check the board to make sure there are no missed joints or accidental
solder bridges.
10) Note the PICAXE-08M chip will require programming before the project will
function. The chip must be programmed on the main rudolf PCB and then moved
across to the infra-red PCB, as the infra-red PCB has no programming socket.
11) Insert the microcontroller into the socket, ensuring pin1 faces the stereo socket.

Infra-red Upgrade Circuit
4.5V
Rudolf the Red Nosed Infrared Circuit

in2
in3

6
5
4

PICAXE 08M

1
in1

3
7
2

out4

330 x 2

out0
sin

IR

LED

3x 10k

8

0V
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Program Explanation
The infra-red system consists of two programs, one on the infra-red tranmsitter PCB and
one on the main Rudolf PCB. The infra-red transmitter program transmits a different
infra-red code for each of the three switches. In the sample program the codes 1,2 and 3
are used, but these can be changed to any number between 0 and 127. To increase
reliability in the system the infra-red code is transmitted ten times when the switch is
pressed. The yellow LED is lit during transmission for user feedback, as the light from the
IR LED is invisible to the human eye.
In the infra-red receiver program the main loop simply waits for a valid infra-red signal.
If this is signal is one of the three pre-programmed codes, a tune is played. Note that
once the infra-red upgrade has been added the push switch on the main Rudolf PCB
(input3) should not be used.
Note it is possible to see if the infra-LED is transmitting by looking at the LED ‘end-on’
through a web-cam or mobile phone camera. These devices will detect infra-red light and
so the LED will visually change colour on the camera screen when transmitting.

Infra-red Transmitter Programmer (infra-red PCB)
(note this must be programmed onto PICAXE-08M by moving the chip onto the main
Rudolf PCB)
' ***** main loop *****
' loop until switch is pressed
main:
if pin1 = 1 then tx_1
if pin2 = 1 then tx_2
if pin3 = 1 then tx_3
goto main
tx_1:
let b1 = 1
goto tx_ir

' Code 1

let b1 = 2
goto tx_ir

' Code 2

let b1 = 3
goto tx_ir

' Code 3

tx_2:

tx_3:

'transmit code 10 times
tx_ir:
high 4
for b2 = 1 to 10
infraout 1,b1
pause 45
next b2
low 4
goto main

for increased reliability
'
'
'
'

yellow LED on
send infrared code 10 times
send code
wait 45 milliseconds

' LED off
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Infra-red Receiver Programmer (main Rudolf PCB)
(note the infra codes used (1,2,3) must match those used in the transmitter program)
' ***** main loop *****
' wait until infrared signal is received
main:
infrain2
' ***** play tune *****
'debug infra

' optional display on screen for testing

' play tune depending on light level
if infra = 3 then play_xmas
if infra = 2 then play_rudolf
if infra = 1 then play_jingle
goto main

Note this must be
typed as one long
line in the software

play_jingle:
play 1,3
goto main

' internal tune Jingle Bells

play_silent:
play 2,3
goto main

' internal tune Silent Night

play_rudolf:
play 3,3
goto main

' internal tune Rudolf The Red Nosed Reindeer

play_xmas:

' external ringtone tune (from Tune Wizard)

' We wish you a Merry Xmas
tune 3, 4, ($22,$27,$67,$69,$67,$66,$24,$24,$24,$29,$69,$6B,$69,$67,
$26,$22,$22,$2B,$6B,$40,$6B,$69,$27,$24,$22,$24,$29,$26,$E7,$22,$27,
$67,$69,$67,$66,$24,$24,$24,$29,$69,$6B,$69,$67,$26,$22,$22,$2B,$6B,
$40,$6B,$69,$27,$24,$22,$24,$29,$26,$A7,$22,$27,$27,$27,$E6,$26,$27,
$26,$24,$E2,$29,$2B,$69,$69,$67,$67,$02,$22,$22,$24,$29,$26,$E7)
goto main
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