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PICAXE VSM Tutorial Part 4

In the fourth part of our PICAXE VSM tutorial we look at how to export a Bill of

Materials (BoM). We also look at how to generate a PCB netlist for use in various PCB
applications.

Bill of Materials
U1
CT1 : VDD — vss 2
) R1 22 S{RXD = PO
RXD | e ——— S lre B m [
[ TXD P3 P2 |——
ov 2
PICAXEO8SM-IC
PICAXE SOCKET R2
10k
.
= R3
330
Sample Program: +
BAT1

main:

high 4 g 2

pause 1000 1 D1

low 4 BATTERY-CONNECTOR LED-RED

pause 1000

goto main

Figure 1 — simple LED circuit

Figure 1 shows the simple PICAXE-OM circuit found in the sample file ‘PCB Export

Demo.DSN’. We will use this file to demonstrate both a Bill of Materials and PCB netlist
export.

At this point is important to note that the ‘voltmeter’ component must have its ‘Exclude

from PCB Layout’ property checked. This is because you do not want it to be included in
either the BoM or PCB layout.
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When an export is performed, the data included within both types of export is defined as
properties within each component symbol. For instance if you right click over the
PICAXE-08M part and select ‘Edit Properties’ you will see the information in Figure 2.
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PIC&XE Program File: | Hidesll -] —
PCB Package: DILOE ~|[2]/Hidean ] =
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Exclude from PCE Layout
Edit all properties as text

Figure 2 — PICAXE-08M properties, showing CODE and PCB Package

The ‘CODE’ property is the order code used within the Bill of Materials. By default these
are set to Revolution’s online store (www.techsupplies.co.uk) order codes, but if you use
a different supplier you can edit the order codes as you choose.

The ‘PCB Package’ property describes the footprint symbol used within the PCB
application. We will come back to this later.
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To generate the actual BoM simply click the Tools>Bill of Materials menu. You will then
see an output similar to Figure 3.

.f:} Bill Of Materials For high command - Proteus HTML Yiewer
File Edit

= = &

Category, Reference,Value, Order Code
Resistors,"R1", 22k, RESZZK
Resistors,"RZ", 10k, RES10K

Resistors, "R3",330,RES330R

Integrated Circuits, "U1",PICAZEOSM-IC, AXEOOTH
Diodes,"D1",LED-RED, LEDOO1
Miscellaneous, "BEATL™, BATTERY-CCNNECTOR, BATO13
Miscellaneous, "CT1", PICAZE SOCEET, CONO39

Figure 3 — Generated BoM

Once the BoM has been saved in the CSV (comma separated variables) text format it can
be imported into a number of other applications e.g. Excel. Figure 4 shows the Excel
layout after the file has been opened and prices added (remember to choose the Text
(CSV) file format when using File>Open within Excel).
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2 Resistars R1 22k REZZ2K 0.m
3 |Resistors R2 10k RES10K 0.01
4 | Resistors R3 330 RES330R 0.m
5 |Integrated CircuilJ1 PICAXEDSM-IC AREDDT M 1.15
6 Diodes D1 LED-RED LEDOOM 0.15
7 Miscellaneous BAT1 BATTERY-CONMMECTOR | BATO13 0.15 L |
8 Miscellaneous CT1 PICAXE SOCKET CON039 0.12
g I 150!
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11
12 -

4 4 » » ] Bill Of Materials For high comm / |4] I

Ready MUM

Figure 4 — Excel with prices added and totalled
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PCB Netlists

PICAXE VSM does not contain a PCB layout feature, but the circuit schematics can be
exported as a netlist to use in a wide variety of popular PCB applications. Over a dozen
different PCB applications are supported by the netlist export option. Our
recommendations would be:

Professional - ARES from www.labcenter.com £150/ $US 300
Educational - realPCB from www.techsupplies.co.uk  £50/ $US 100
Budget - Eagle from www.cadsoft.de Free version

In this tutorial we will consider both the ARES and realPCB options.

Figure 1 shows a circuit suitable for generating a PCB netlist. The most important point
to note is the addition of the battery connector part — after all you need somewhere to
connect the power supply to your PCB! So this part has no affect on the simulation (and
indeed should be excluded from the simulation) but is essential to ensure the PCB is
correctly generated — otherwise there will be no pads on the PCB to connect the power

supply!

To transfer to ARES or realPCB we need to create a ‘netlist file’. A netlist contains
connection information about the components in the design — e.g. in our case that the
LED D1 is connected to resistor R3 and OV. For a netlist to operate correctly the
components in the schematic must know the name of the corresponding footprint symbol
in the PCB software — for instance that the PICAXE IC uses the 8 pin DIL IC format
footprint.

This information is stored as the ‘PCB package’ property. If you right click over the
PICAXE-08M symbol and select ‘Edit Properties’, you will see the PCB package name
for this part is ‘DIL08’ (see Figure 2). This is actually the footprint name used by the
ARES package (we will come back to how the realPCB footprint name is defined later).
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Netlist Compiler
Netlist Compiler @El
Dutput: Foarmat:
* Vi e
- Filefs} <" Eedesigner
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Lk < Spice
< Physzical < Tanga
< Logical < Ubrax
< Boardmaker
Scope: ; ;uturTnet
< Current Sheet P S;izae-r-‘-.ge
- Whale Design / RealPTE
Diepth:
< This Level L
- Flatten Cancel

Figure 5 — Netlist export options showing PCB applications supported.

To export a netlist select the Tools>Netlist Compiler menu. The most important option is
the Format as not all netlist formats are the same. So select ‘SDF’ for ARES, ‘RealPCB’
for realPCB and ‘Multiwire/Eagle’ for Eagle.

The Output option is normally used on File, to save the netlist directly to a file on your
hard-drive. However if you first want to preview the netlist, select Viewer instead. This
will display the contents of the netlist on-screen after it is generated — it can then be saved
if desired. Depth, Scope and Mode should all be left on the defaults shown.
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515 NETLIST - ISIS for PICAXE VSH

FORMAT, CROCODILENETLIST, 1
;Generated by ISIS for PICAXE VSM from design high command

CCMPONENTFIELDS, "Value"

HET, "NOO1", "Signal®
HET, "NOO2", "Signal"
NET, "NOO4", "Signal"
HET, "NOO5", "Signal”
NET, "NOOG", "Signal”
NET, "&ND", "Power"

NET, "WCC™, "Power"”

CCMPONENT, BAT1, "Battery”, "Connectors.cwl”™, "EATTERY-CONNECTOR™
PIN,BATL, 1, "GND"
PIN,BATL,Z,"VCC"

CCMPONENT, CTL1, "PICAXE Download ZSocket™, "Microcontrollers.cwl™, "PICAXE SOCKET"
PIN,CT1,1," 003"
PIN,CT1,2,"N004"
PIN,CTL1,3,"GND"

CCMEONENT, D1, "LED (white Smm) ", "Light Outputs.cwl”, "LED-RED"
PIN,D1,Z,"NOOL"™
PIN,D1,1,"GND"

COMPONENT, R1, "Resistor", "Passive Cowponents.cml™, "2Z2k"
PIN,E1,1,™NOO4"
PIN,R1,2,"NOOE"

CCMPONENT, B2, "Resistor”, "Passive Components.cml™, "10k"
PIN,RZ,1,"™NO04"
PIN,EZ,2,"GND"

CCMPONENT, B3, "Resistor”, "Passive Cowponents.cml™, "3307
FIN,R3, 1, "NOOS"™
FIN,R3,Z,"HOO1"™

CCMPONENT, U1, "08DIL", "PCE Footprints.cml”, "PICAXEOSM-IC"
PIN, UL, 1, "vee!

PIN,U1,2, "HOOE"

PIN,U1,3, "HOOS"

PIN,U1,7,"HOO3"

PIN,U1,8, "GND"

Figure 6 - sample real PCB netlist content.
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Importing into ARES.

Once the netlist is generated, start up the ARES application and select File>Load Netlist.
Browse to and open the .SDF netlist file. The components will all be placed in the object
selector, and after manual placing will appear as in figure 7 (obviously you will probably
layout differently!) The nets will be shown as lines — this is commonly known as a ‘rats-
nest’ layout as the tracks are not yet drawn.

BHES UNTITLED - ARES Professional.

File Cutput Yiew Edt Lbrary Tooks System Help

DEE @G e | d6 B Ak

il m+F|+RQA8Q |9 & B[ o0 | 68 g | 2R | ot L

w1 J0Q N +EFr8 0D @REOBODO|CXELroE v r

[ Top Sik ~| || #F |3 %@ | T K| L ||[ONTILED.LYT Ho DRC errars 23000 +1400.0

Figure 7 — ARES layout before auto-routing.

F
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Now select Tools>Autorouter menu to change your ’rats-nest’ into a proper PCB, as
shown in Figure 8. Naturally this sample design could be tidied up by moving the parts
closer and rearranging!

Hi5 UNTITLED - ARES Professional (=13
File Qutput Yiew Edit Lbrary Tools System Help
DEHE @G &8 A6 |BAGD M| 480 |9 @& EE A A 2™

w1 J0Q N +EFr8 0D @REOBODO|CXELroE v r

[ Top Sik ~| || #F |3 %@ | T K| L ||[ONTILED.LYT Ho DRC errars 26000 +1350.0  th

Figure 8 — ARES layout after auto-routing.

Now the design can be manually completed and used to produce manufacturing Gerber
files if required.
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Importing into realPCB.

Once the netlist is generated, start up the realPCB application and select the File>Import
menu. Browse to and open the .CIR netlist file.

realPCB has a fully automated import so if you simply click ‘Next’ through all the import
wizard stages you will end up with a PCB layout as shown in Figure 9

iii» realPCB - [pch export demo. pch]

(P Ble Edt Vew Add Settngs Iook Window Help
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Figure 9 — realPCB layout after single sided import
Naturally you will probably want to move the components and tidy up the design

manually after the import. Then the design can be manually completed and used to
produce manufacturing Gerber files if required.
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realPCB Mapping File

As the realPCB footprint names do not always match the ARES footprint names, a
special mapping file called realPCB.adi is found in the PICAXE VSM\LIBRARY folder.
This file defines how the ‘PCB Package’ (ARES footprint) property is translated to a
realPCB footprint name upon the realPCB netlist export. If required this file can be edited
by the end user to add additional translations or modify existing translations.

[P REALPCB.ADI - Notepad FBEX

File Edit Format Wiew Help

h This file describes rules for package and pin translation from Proteus to realPCB A
i a1l packages within ISIs are in Proteus ARES format

; This file translates to hest suitable part in realpce

i vou can swap pins over wia the fourth column, "proteus_pin_name = realpch_pin_name”
DATA PACKAGE : REALPCE_LIEBRARY, REALPCE_PACKAGE, REALPCE_PINS

CONN-SILZ : "Connectors.aml”, “"Header (2 pole)”, [sKkIF]

COMN-SIL3 : "Connectors.cml”, “Header (3 pole)", [sKIP]

COMN-STIL4 r "Connectors.aml”, "Header (4 pole)”, [=KIP]

COMNMN-SILS i "Connectors.cml”, "Header (5 polel”, [sKIP]

COMNN-SILG : "PCB Footprints.cml", "065IL", [SKIP]

CONN-SILS : "PCBE FDDtpr“'lnts.cm'l", "OSSIL", [SKIP]

COMN-SILD : "PCB Fuutprints.cm1 ‘oosIL” [SKIP]

CONN-SILLO : "Connectors.aml”, Header (10 polel”, [sKkIF]

DILO4 : "PCB Footprints.cml", "04DIL", [SKIP]

DILOGE : "PCB Footprints.aml', "0s0IL” [skIP]

DILOR : "PCE Footprints.cml", "08DIL", [SKIF]

DIL14 : "PCE Footprints.aml', "l4pIL", [SKIP]

DIL1G : "PCE Footprints.cml", "l6DIL", [SKIF]

DIL1S : "PCE Footprints.oml', "18D0IL", [SKIP]

DILZ0 : "PCBE Footprints.cml", "20DIL", [SKIF]

DILZ22 : "PCE Footprinmts.aml™, "Z220ILY, SKIP:

DILZ24 i "PCE Footprints.cml", "Z24DIL (w1de) [sKIP]
DILZ24MAR : "PCB Footprints.cml", "24DIL (narrow) . [sKIF]

DILZ28 : "PCB Footprints.aml', "ZEDIL Cwided", [sKIF]
DILZBMNAR : "PCE Footprints.cml”, "28DIL Charrow)”, [sKIF]

DIL40 : "PCB Footprints.aml', "400IL", [sKkIF]

DILG4 : ”PCB Fuutprints.cm1”, "A4DIL", [sKkIP]

LED : L1ght outputs. cml” "LED (white Smm)", "a=2,Kk=1"
LOR : Input Components. cm1”, "LDR Cminiaturel™, [sKIF]

TO3 : "PCE Footprints.aml’, "To3", [SKIP]

TOLR : "PCE Footprints.cml”, "Told", [sKIF]

TO39 : "PCE Footprints.aml', "To3o", [SKIF]

TOG2 : "PCE Footprints.cml”, "To9z2", [SKIP]

ELINE : "PCE Footprints.aml™, "Tos2", "1=3,2=2,3=1"

TO92-2 i "PCE Footprints.cml", "To%2a", [sKIP]

TOO2-100 : "PCE Footprints.aml™, “T092“, [sKIP]

TOZ220 i "PCE Footprints.cml”, "Toz2z20" [sKIP]

= : "PCBE Footprints.cml”, T0220 [skIP]

RES40 : "Passive Components. cm1“ Res1st0r“, [sKIF]
DIODEZS : "Discrete Semicunductors.cm1“, "1N4148 Diode”, “as=1,K=2"
DIODE3D : "piscrete semiconductors.oml”, "1n4001 Diode”, "a=l,k=2"
DIODE4AD : "Discrete semiconductors.coml”, "1n4001 Diode”, "as=1,K=2"
Do35 : "Discrete semiconductors.oml”, "1W4001 Diode”, "a=l,K=2"
Do35 : "Discrete semiconductors.coml”, "1n4148 Diode”, “as=l,K=2"
Do41 : "Discrete Semiconductors.cmW“, "Zener Diode", "as=l,k=2"

COMNN-DIL14 : ”PCB Fuutprints.cm1' "l4pIL" [SKIP]

?SEG 56 r "Light outputs.aml”, "7 Seg LEDCCA)
E11D12CA13C14DPlSBlﬁAl?FlQGllO

PICAXE-SOCKET 0 M1cr0c0ntr011ers cm1 "PICAXE Duwn10ad socket” [sKIP]
RESOMATCOR : ”Micrucuntro11ers.cm1”, "Resonator”, [SKIP] v

Figure 10 — realPCB mapping file
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